PubReader Supported Browsers

At present, PubReader supports the following platforms and browsers.

Browser version Windows Mac OSX Linux iOS (iPad) Android
Firefox 14 or greater This version is supported by PubReader. This version is supported by PubReader. This version is supported by PubReader. N/A This version might work with PubReader.
Chrome 20 or greater This version is supported by PubReader. This version is supported by PubReader. This version is supported by PubReader. This version is supported by PubReader. This version is supported by PubReader.
Safari 5 or greater This version might work with PubReader. This version is supported by PubReader. N/A N/A N/A
Mobile Safari 5 or greater N/A N/A N/A This version is supported by PubReader. N/A
Android browser 4 or greater N/A N/A N/A N/A This version is supported by PubReader.
Internet Explorer 10 or greater This version is supported by PubReader. N/A N/A N/A N/A
Opera / Opera Mobile 12 or greater This version might work with PubReader. This version does not work with PubReader. N/A This version might work with PubReader. This version might work with PubReader.
  • Tick mark icon, for supported browsers Supported
  • Cross Error Icon, for not support browsers Not supported
  • Warning Icon, for browsers that have not been tested Not tested
Write to the Help Desk

Last updated: Wed, 18 Dec 2013